Errors loading images
Incident Report for BetterNow
Resolved
This incident has been resolved.
Posted Oct 07, 2022 - 07:36 UTC
Monitoring
Our upstream providers have applied a fix. We continue to monitor for errors.
Posted Oct 07, 2022 - 06:41 UTC
Identified
Our upstream providers have confirmed that there are intermittent problems loading the images from some European countries. We are working with them on a resolution to this issue.
Posted Oct 07, 2022 - 06:11 UTC
Investigating
We are currently investigating this issue. Our monitoring shows intermittent errors loading images. We are in contact with our upstream providers regarding this issue.
Posted Oct 07, 2022 - 05:54 UTC
This incident affected: images.yourbetternow.org.